summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2015-12-17 16:07:59 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2015-12-17 16:07:59 -0500
commitf9fa596fbf85c0e0014a4db508b239ef58f5477a (patch)
treea7f6c94a9476a1658e1fb08bf09ece1ce75e6214 /CMakeLists.txt
parent428c401f9c1053f7e13ffe641758dfb72791d8dc (diff)
parent1405c1b7c42d26cfeeee8e08a44bd0e2ef2906b7 (diff)
downloadtherapy-f9fa596fbf85c0e0014a4db508b239ef58f5477a.tar.gz
therapy-f9fa596fbf85c0e0014a4db508b239ef58f5477a.tar.bz2
therapy-f9fa596fbf85c0e0014a4db508b239ef58f5477a.zip
Merge branch 'master' of http://github.com/hatkirby/therapy into es-rewrite
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 9e4ac25..553d757 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -21,18 +21,20 @@ elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL "MSVC")
21 endif() 21 endif()
22endif() 22endif()
23 23
24find_package(PkgConfig)
25
24# Look up SDL2 and add the include directory to our include path 26# Look up SDL2 and add the include directory to our include path
25find_package(OpenGL REQUIRED) 27find_package(OpenGL REQUIRED)
26find_package(GLEW REQUIRED) 28find_package(GLEW REQUIRED)
27find_package(GLFW REQUIRED) 29pkg_check_modules(GLFW REQUIRED glfw3)
28find_package(portaudio REQUIRED) 30find_package(portaudio REQUIRED)
29find_package(libsndfile REQUIRED) 31find_package(libsndfile REQUIRED)
30find_package(libxml2 REQUIRED) 32find_package(libxml2 REQUIRED)
31 33
32set(ALL_LIBS 34set(ALL_LIBS
33 ${OPENGL_LIBRARY} 35 ${OPENGL_LIBRARIES}
34 ${GLEW_LIBRARY} 36 ${GLEW_LIBRARIES}
35 ${GLFW_LIBRARY} 37 ${GLFW_LIBRARIES}
36 ${PORTAUDIO_LIBRARIES} 38 ${PORTAUDIO_LIBRARIES}
37 ${LIBSNDFILE_LIBRARY} 39 ${LIBSNDFILE_LIBRARY}
38 ${LIBXML2_LIBRARIES} 40 ${LIBXML2_LIBRARIES}
@@ -40,6 +42,7 @@ set(ALL_LIBS
40 42
41include_directories( 43include_directories(
42 ${LIBXML2_INCLUDE_DIR} 44 ${LIBXML2_INCLUDE_DIR}
45 ${GLFW_INCLUDE_DIRS}
43 src 46 src
44) 47)
45 48