summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-02-11 12:34:52 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-02-11 12:34:52 -0500
commit77be863f4f15d2481a64e4e8dadb4060a6e4e590 (patch)
treeca571702d2148a75b5b847e77d26270257f54ebc /CMakeLists.txt
parent1400ade977e13e3b535d3c2fddb6e15de3c9b5a5 (diff)
downloadtherapy-77be863f4f15d2481a64e4e8dadb4060a6e4e590.tar.gz
therapy-77be863f4f15d2481a64e4e8dadb4060a6e4e590.tar.bz2
therapy-77be863f4f15d2481a64e4e8dadb4060a6e4e590.zip
Implemented map rendering and basic collision
Only wall and platform collision currently works, and map edges are not currently implemented.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 1da4432..f918156 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -61,9 +61,11 @@ add_executable(Aromatherapy
61 src/entity_manager.cpp 61 src/entity_manager.cpp
62 src/game.cpp 62 src/game.cpp
63 src/animation.cpp 63 src/animation.cpp
64 src/world.cpp
64 src/systems/controlling.cpp 65 src/systems/controlling.cpp
65 src/systems/pondering.cpp 66 src/systems/pondering.cpp
66 src/systems/animating.cpp 67 src/systems/animating.cpp
68 src/systems/mapping.cpp
67) 69)
68target_link_libraries(Aromatherapy ${ALL_LIBS}) 70target_link_libraries(Aromatherapy ${ALL_LIBS})
69install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 71install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})