diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 27 |
1 files changed, 25 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index ed3f7e7..b1a7b38 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -9,15 +9,20 @@ pkg_check_modules(lept lept REQUIRED) | |||
9 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | 9 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) |
10 | pkg_check_modules(tclap tclap REQUIRED) | 10 | pkg_check_modules(tclap tclap REQUIRED) |
11 | pkg_check_modules(curlcpp curlcpp REQUIRED) | 11 | pkg_check_modules(curlcpp curlcpp REQUIRED) |
12 | find_package(websocketpp) | ||
12 | 13 | ||
13 | include_directories( | 14 | include_directories( |
14 | vendor/json | 15 | vendor/json |
15 | vendor/hkutil | 16 | vendor/hkutil |
17 | vendor/asio/asio/include | ||
18 | vendor/base64/include | ||
19 | vendor/stduuid | ||
16 | ${tesseract_INCLUDE_DIRS} | 20 | ${tesseract_INCLUDE_DIRS} |
17 | ${lept_INCLUDE_DIRS} | 21 | ${lept_INCLUDE_DIRS} |
18 | ${GraphicsMagick_INCLUDE_DIRS} | 22 | ${GraphicsMagick_INCLUDE_DIRS} |
19 | ${curlcpp_INCLUDE_DIRS} | 23 | ${curlcpp_INCLUDE_DIRS} |
20 | ${tclap_INCLUDE_DIRS} | 24 | ${tclap_INCLUDE_DIRS} |
25 | ${WEBSOCKETPP_INCLUDE_DIR} | ||
21 | ) | 26 | ) |
22 | 27 | ||
23 | link_directories( | 28 | link_directories( |
@@ -25,10 +30,11 @@ link_directories( | |||
25 | ${lept_LIBRARY_DIRS} | 30 | ${lept_LIBRARY_DIRS} |
26 | ${GraphicsMagick_LIBRARY_DIRS} | 31 | ${GraphicsMagick_LIBRARY_DIRS} |
27 | ${curlcpp_LIBRARY_DIRS} | 32 | ${curlcpp_LIBRARY_DIRS} |
33 | ${websocketpp_LIBRARY_DIRS} | ||
28 | ) | 34 | ) |
29 | 35 | ||
30 | add_executable(wizard cardset.cpp imagestore.cpp designer.cpp wizard.cpp main.cpp) | 36 | add_library(wizard cardset.cpp imagestore.cpp designer.cpp wizard.cpp) |
31 | set_property(TARGET wizard PROPERTY CXX_STANDARD 14) | 37 | set_property(TARGET wizard PROPERTY CXX_STANDARD 17) |
32 | set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON) | 38 | set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON) |
33 | target_link_libraries( | 39 | target_link_libraries( |
34 | wizard | 40 | wizard |
@@ -37,3 +43,20 @@ target_link_libraries( | |||
37 | ${GraphicsMagick_LIBRARIES} | 43 | ${GraphicsMagick_LIBRARIES} |
38 | ${curlcpp_LIBRARIES} | 44 | ${curlcpp_LIBRARIES} |
39 | ) | 45 | ) |
46 | |||
47 | add_executable(wizard_gen main.cpp) | ||
48 | set_property(TARGET wizard_gen PROPERTY CXX_STANDARD 17) | ||
49 | set_property(TARGET wizard_gen PROPERTY CXX_STANDARD_REQUIRED ON) | ||
50 | target_link_libraries( | ||
51 | wizard_gen | ||
52 | wizard | ||
53 | ) | ||
54 | |||
55 | add_executable(wizard_server database.cpp server_main.cpp) | ||
56 | set_property(TARGET wizard_server PROPERTY CXX_STANDARD 17) | ||
57 | set_property(TARGET wizard_server PROPERTY CXX_STANDARD_REQUIRED ON) | ||
58 | target_link_libraries( | ||
59 | wizard_server | ||
60 | wizard | ||
61 | ${websocketpp_LIBRARIES} | ||
62 | ) | ||