summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStar Rauchenberger <fefferburbia@gmail.com>2024-11-04 11:46:24 -0500
committerStar Rauchenberger <fefferburbia@gmail.com>2024-11-04 11:46:24 -0500
commit8375f92802d3aa7667bfc6f22f6d2a72361c9808 (patch)
treebb706d3493d1ed7043387a3cb9e6a4d1897acba4 /CMakeLists.txt
parent460b99583bcf6da4462f13ad75856283849904e7 (diff)
downloadwizard-8375f92802d3aa7667bfc6f22f6d2a72361c9808.tar.gz
wizard-8375f92802d3aa7667bfc6f22f6d2a72361c9808.tar.bz2
wizard-8375f92802d3aa7667bfc6f22f6d2a72361c9808.zip
Websockets server!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 25 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index ed3f7e7..b1a7b38 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -9,15 +9,20 @@ pkg_check_modules(lept lept REQUIRED)
9pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 9pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
10pkg_check_modules(tclap tclap REQUIRED) 10pkg_check_modules(tclap tclap REQUIRED)
11pkg_check_modules(curlcpp curlcpp REQUIRED) 11pkg_check_modules(curlcpp curlcpp REQUIRED)
12find_package(websocketpp)
12 13
13include_directories( 14include_directories(
14 vendor/json 15 vendor/json
15 vendor/hkutil 16 vendor/hkutil
17 vendor/asio/asio/include
18 vendor/base64/include
19 vendor/stduuid
16 ${tesseract_INCLUDE_DIRS} 20 ${tesseract_INCLUDE_DIRS}
17 ${lept_INCLUDE_DIRS} 21 ${lept_INCLUDE_DIRS}
18 ${GraphicsMagick_INCLUDE_DIRS} 22 ${GraphicsMagick_INCLUDE_DIRS}
19 ${curlcpp_INCLUDE_DIRS} 23 ${curlcpp_INCLUDE_DIRS}
20 ${tclap_INCLUDE_DIRS} 24 ${tclap_INCLUDE_DIRS}
25 ${WEBSOCKETPP_INCLUDE_DIR}
21) 26)
22 27
23link_directories( 28link_directories(
@@ -25,10 +30,11 @@ link_directories(
25 ${lept_LIBRARY_DIRS} 30 ${lept_LIBRARY_DIRS}
26 ${GraphicsMagick_LIBRARY_DIRS} 31 ${GraphicsMagick_LIBRARY_DIRS}
27 ${curlcpp_LIBRARY_DIRS} 32 ${curlcpp_LIBRARY_DIRS}
33 ${websocketpp_LIBRARY_DIRS}
28) 34)
29 35
30add_executable(wizard cardset.cpp imagestore.cpp designer.cpp wizard.cpp main.cpp) 36add_library(wizard cardset.cpp imagestore.cpp designer.cpp wizard.cpp)
31set_property(TARGET wizard PROPERTY CXX_STANDARD 14) 37set_property(TARGET wizard PROPERTY CXX_STANDARD 17)
32set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON) 38set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON)
33target_link_libraries( 39target_link_libraries(
34 wizard 40 wizard
@@ -37,3 +43,20 @@ target_link_libraries(
37 ${GraphicsMagick_LIBRARIES} 43 ${GraphicsMagick_LIBRARIES}
38 ${curlcpp_LIBRARIES} 44 ${curlcpp_LIBRARIES}
39) 45)
46
47add_executable(wizard_gen main.cpp)
48set_property(TARGET wizard_gen PROPERTY CXX_STANDARD 17)
49set_property(TARGET wizard_gen PROPERTY CXX_STANDARD_REQUIRED ON)
50target_link_libraries(
51 wizard_gen
52 wizard
53)
54
55add_executable(wizard_server database.cpp server_main.cpp)
56set_property(TARGET wizard_server PROPERTY CXX_STANDARD 17)
57set_property(TARGET wizard_server PROPERTY CXX_STANDARD_REQUIRED ON)
58target_link_libraries(
59 wizard_server
60 wizard
61 ${websocketpp_LIBRARIES}
62)