summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 9e0bd52..553d757 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -50,22 +50,18 @@ include_directories(
50set(CMAKE_BUILD_TYPE Debug) 50set(CMAKE_BUILD_TYPE Debug)
51add_executable(Aromatherapy 51add_executable(Aromatherapy
52 src/main.cpp 52 src/main.cpp
53 src/map.cpp
54 src/renderer.cpp 53 src/renderer.cpp
55 src/entity.cpp
56 src/game.cpp
57 src/muxer.cpp 54 src/muxer.cpp
58 src/entityfactory.cpp 55 src/entity_manager.cpp
59 src/world.cpp 56 src/game.cpp
60 src/components/ai.cpp 57 src/components/transformable.cpp
61 src/components/map_collision.cpp 58 src/components/droppable.cpp
62 src/components/map_render.cpp 59 src/components/controllable.cpp
63 src/components/physics_body.cpp 60 src/components/ponderable.cpp
64 src/components/player_physics.cpp 61 src/components/animatable.cpp
65 src/components/player_sprite.cpp 62 src/systems/rendering.cpp
66 src/components/simple_collider.cpp 63 src/systems/controlling.cpp
67 src/components/static_image.cpp 64 src/systems/pondering.cpp
68 src/components/user_movement.cpp
69) 65)
70target_link_libraries(Aromatherapy ${ALL_LIBS}) 66target_link_libraries(Aromatherapy ${ALL_LIBS})
71install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 67install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})