summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 2622733..a006f67 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -26,8 +26,14 @@ find_package(OpenGL REQUIRED)
26find_package(GLEW REQUIRED) 26find_package(GLEW REQUIRED)
27find_package(GLFW REQUIRED) 27find_package(GLFW REQUIRED)
28 28
29set(ALL_LIBS
30 ${OPENGL_LIBRARY}
31 ${GLEW_LIBRARY}
32 ${GLFW_LIBRARY}
33)
34
29# include_directories(${SDL2_INCLUDE_DIR}) 35# include_directories(${SDL2_INCLUDE_DIR})
30set(CMAKE_BUILD_TYPE Debug) 36set(CMAKE_BUILD_TYPE Debug)
31add_executable(Aromatherapy src/main.cpp src/map.cpp src/mapview.cpp src/renderer.cpp) 37add_executable(Aromatherapy src/main.cpp src/map.cpp src/mapview.cpp src/renderer.cpp)
32target_link_libraries(Aromatherapy ${OPENGL_LIBRARY} ${GLEW_LIBRARY} ${GLFW_LIBRARY}) 38target_link_libraries(Aromatherapy ${ALL_LIBS})
33install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 39install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})