summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2015-02-21 19:21:17 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2015-02-21 19:21:17 -0500
commitcecdba5cd996cea3ebd2534aea7a3e3a41205b9c (patch)
treee955d61534a17678fe6f0e17b69f506f9d03a948 /CMakeLists.txt
parent59860415a2782694f630f7803ae4bcf445b3f5f1 (diff)
downloadtherapy-cecdba5cd996cea3ebd2534aea7a3e3a41205b9c.tar.gz
therapy-cecdba5cd996cea3ebd2534aea7a3e3a41205b9c.tar.bz2
therapy-cecdba5cd996cea3ebd2534aea7a3e3a41205b9c.zip
Changed to using stb_image for image loading, also alpha blending works!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 2622733..a006f67 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -26,8 +26,14 @@ find_package(OpenGL REQUIRED)
26find_package(GLEW REQUIRED) 26find_package(GLEW REQUIRED)
27find_package(GLFW REQUIRED) 27find_package(GLFW REQUIRED)
28 28
29set(ALL_LIBS
30 ${OPENGL_LIBRARY}
31 ${GLEW_LIBRARY}
32 ${GLFW_LIBRARY}
33)
34
29# include_directories(${SDL2_INCLUDE_DIR}) 35# include_directories(${SDL2_INCLUDE_DIR})
30set(CMAKE_BUILD_TYPE Debug) 36set(CMAKE_BUILD_TYPE Debug)
31add_executable(Aromatherapy src/main.cpp src/map.cpp src/mapview.cpp src/renderer.cpp) 37add_executable(Aromatherapy src/main.cpp src/map.cpp src/mapview.cpp src/renderer.cpp)
32target_link_libraries(Aromatherapy ${OPENGL_LIBRARY} ${GLEW_LIBRARY} ${GLFW_LIBRARY}) 38target_link_libraries(Aromatherapy ${ALL_LIBS})
33install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 39install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})