summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 18 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index e86cd95..7c9084e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -40,10 +40,27 @@ set(ALL_LIBS
40 40
41include_directories( 41include_directories(
42 ${LIBXML2_INCLUDE_DIR} 42 ${LIBXML2_INCLUDE_DIR}
43 src
43) 44)
44 45
45# include_directories(${SDL2_INCLUDE_DIR}) 46# include_directories(${SDL2_INCLUDE_DIR})
46set(CMAKE_BUILD_TYPE Debug) 47set(CMAKE_BUILD_TYPE Debug)
47add_executable(Aromatherapy src/main.cpp src/map.cpp src/renderer.cpp src/entity.cpp src/components.cpp src/game.cpp src/muxer.cpp src/entityfactory.cpp) 48add_executable(Aromatherapy
49 src/main.cpp
50 src/map.cpp
51 src/renderer.cpp
52 src/entity.cpp
53 src/game.cpp
54 src/muxer.cpp
55 src/entityfactory.cpp
56 src/components/map_collision.cpp
57 src/components/map_render.cpp
58 src/components/physics_body.cpp
59 src/components/player_physics.cpp
60 src/components/player_sprite.cpp
61 src/components/simple_collider.cpp
62 src/components/static_image.cpp
63 src/components/user_movement.cpp
64)
48target_link_libraries(Aromatherapy ${ALL_LIBS}) 65target_link_libraries(Aromatherapy ${ALL_LIBS})
49install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 66install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})