summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-02-18 12:35:45 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-02-18 12:35:45 -0500
commite16fb5be90c889c371cbb0ca2444735c2e12073c (patch)
treecbaa20e14a34c460b6c9886f266c4b4b6f62ae87 /CMakeLists.txt
parented08b673c50b076042d8f0c49501372168142764 (diff)
downloadtherapy-e16fb5be90c889c371cbb0ca2444735c2e12073c.tar.gz
therapy-e16fb5be90c889c371cbb0ca2444735c2e12073c.tar.bz2
therapy-e16fb5be90c889c371cbb0ca2444735c2e12073c.zip
Implemented map adjacency
This brings along with it the ability to move to different maps, for which the PlayingSystem and PlayableComponent were introduced. The PlayingSystem is a general overseer system that handles big picture stuff like initializing the player and changing maps. The PlayableComponent represents the player. While the ControllableComponent is also likely to always only be on the player entity, the two are distinct by separation of concerns.

This also required a refactoring of how collisions are processed, because of a bug where the player can move to a new map when horizontal collisions are checked, and vertical collisions are skipped, causing the player to clip through the ground because the normal force was never handled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 3e7bcb8..155063e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -55,6 +55,7 @@ add_executable(Aromatherapy
55 src/animation.cpp 55 src/animation.cpp
56 src/world.cpp 56 src/world.cpp
57 src/util.cpp 57 src/util.cpp
58 src/collision.cpp
58 src/renderer/renderer.cpp 59 src/renderer/renderer.cpp
59 src/renderer/mesh.cpp 60 src/renderer/mesh.cpp
60 src/renderer/shader.cpp 61 src/renderer/shader.cpp
@@ -64,6 +65,7 @@ add_executable(Aromatherapy
64 src/systems/animating.cpp 65 src/systems/animating.cpp
65 src/systems/mapping.cpp 66 src/systems/mapping.cpp
66 src/systems/orienting.cpp 67 src/systems/orienting.cpp
68 src/systems/playing.cpp
67) 69)
68 70
69set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 11) 71set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 11)