summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-05-17 15:55:37 -0400
committerGitHub <noreply@github.com>2018-05-17 15:55:37 -0400
commit90aadf3844386824140a20d7fbb847bc16009a94 (patch)
tree6f83fce90e71abb22b1a8f3e09c79963b2a34d5d /CMakeLists.txt
parentbc63fa57ced1c7329f7fdcfd168eaf7e290158bc (diff)
parent86f0106d0523825549f1e74b835688c78a10cf6c (diff)
downloadtherapy-90aadf3844386824140a20d7fbb847bc16009a94.tar.gz
therapy-90aadf3844386824140a20d7fbb847bc16009a94.tar.bz2
therapy-90aadf3844386824140a20d7fbb847bc16009a94.zip
Merge pull request #7 from hatkirby/es-rewrite
The ECS rewrite exceeds the original branch in functionality, so it is time to merge it in.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt51
1 files changed, 33 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 567936a..837df0d 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -16,14 +16,25 @@ find_package(GLEW REQUIRED)
16find_package(portaudio REQUIRED) 16find_package(portaudio REQUIRED)
17find_package(libsndfile REQUIRED) 17find_package(libsndfile REQUIRED)
18find_package(libxml2 REQUIRED) 18find_package(libxml2 REQUIRED)
19find_package(lua REQUIRED)
20
21IF(APPLE)
22 FIND_LIBRARY(COCOA_LIBRARY Cocoa)
23 FIND_LIBRARY(CV_LIBRARY CoreVideo)
24 FIND_LIBRARY(IO_LIBRARY IOKit)
25 MARK_AS_ADVANCED (COCOA_LIBRARY CV_LIBRARY IO_LIBRARY)
26 SET(EXTRA_LIBS ${COCOA_LIBRARY} ${CV_LIBRARY} ${IO_LIBRARY})
27ENDIF (APPLE)
19 28
20set(ALL_LIBS 29set(ALL_LIBS
21 ${OPENGL_LIBRARIES} 30 ${OPENGL_gl_LIBRARY}
22 ${GLEW_LIBRARIES} 31 ${GLEW_LIBRARIES}
23 ${GLFW_LIBRARIES} 32 ${GLFW_LIBRARIES}
24 ${PORTAUDIO_LIBRARIES} 33 ${PORTAUDIO_LIBRARIES}
25 ${LIBSNDFILE_LIBRARY} 34 ${LIBSNDFILE_LIBRARY}
26 ${LIBXML2_LIBRARIES} 35 ${LIBXML2_LIBRARIES}
36 ${LUA_LIBRARIES}
37 ${EXTRA_LIBS}
27) 38)
28 39
29include_directories( 40include_directories(
@@ -31,7 +42,9 @@ include_directories(
31 ${GLFW_INCLUDE_DIRS} 42 ${GLFW_INCLUDE_DIRS}
32 ${OPENGL_INCLUDE_DIRS} 43 ${OPENGL_INCLUDE_DIRS}
33 ${GLEW_INCLUDE_DIRS} 44 ${GLEW_INCLUDE_DIRS}
45 ${LUA_INCLUDE_DIRS}
34 src 46 src
47 vendor
35) 48)
36 49
37link_directories( 50link_directories(
@@ -40,25 +53,27 @@ link_directories(
40 53
41add_executable(Aromatherapy 54add_executable(Aromatherapy
42 src/main.cpp 55 src/main.cpp
43 src/map.cpp
44 src/renderer.cpp
45 src/entity.cpp
46 src/game.cpp
47 src/muxer.cpp 56 src/muxer.cpp
48 src/entityfactory.cpp 57 src/entity_manager.cpp
49 src/world.cpp 58 src/game.cpp
50 src/components/ai.cpp 59 src/animation.cpp
51 src/components/map_collision.cpp 60 src/util.cpp
52 src/components/map_render.cpp 61 src/renderer/renderer.cpp
53 src/components/physics_body.cpp 62 src/renderer/mesh.cpp
54 src/components/player_physics.cpp 63 src/renderer/shader.cpp
55 src/components/player_sprite.cpp 64 src/renderer/texture.cpp
56 src/components/pondering.cpp 65 src/systems/controlling.cpp
57 src/components/simple_collider.cpp 66 src/systems/pondering.cpp
58 src/components/static_image.cpp 67 src/systems/animating.cpp
59 src/components/user_movement.cpp 68 src/systems/mapping.cpp
69 src/systems/orienting.cpp
70 src/systems/playing.cpp
71 src/systems/scheduling.cpp
72 src/systems/realizing.cpp
73 src/systems/scripting.cpp
74 vendor/stb_image.cpp
60) 75)
61 76
62set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 11) 77set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD 17)
63set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD_REQUIRED ON) 78set_property(TARGET Aromatherapy PROPERTY CXX_STANDARD_REQUIRED ON)
64target_link_libraries(Aromatherapy ${ALL_LIBS}) 79target_link_libraries(Aromatherapy ${ALL_LIBS})