summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2015-03-14 16:13:11 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2015-03-14 16:13:11 -0400
commit44324ba5d6cac01048cc5cbecbff255ee56f2fc0 (patch)
tree63e859067d214bfccf1d75520e1cedece0e91963 /CMakeLists.txt
parent5990e7802c84b3f407de3934a1d75721115d1da7 (diff)
downloadtherapy-44324ba5d6cac01048cc5cbecbff255ee56f2fc0.tar.gz
therapy-44324ba5d6cac01048cc5cbecbff255ee56f2fc0.tar.bz2
therapy-44324ba5d6cac01048cc5cbecbff255ee56f2fc0.zip
Wrote simple factory to read map and entity data from XML files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 0b28397..e86cd95 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ find_package(GLEW REQUIRED)
27find_package(GLFW REQUIRED) 27find_package(GLFW REQUIRED)
28find_package(portaudio REQUIRED) 28find_package(portaudio REQUIRED)
29find_package(libsndfile REQUIRED) 29find_package(libsndfile REQUIRED)
30find_package(libxml2 REQUIRED)
30 31
31set(ALL_LIBS 32set(ALL_LIBS
32 ${OPENGL_LIBRARY} 33 ${OPENGL_LIBRARY}
@@ -34,10 +35,15 @@ set(ALL_LIBS
34 ${GLFW_LIBRARY} 35 ${GLFW_LIBRARY}
35 ${PORTAUDIO_LIBRARIES} 36 ${PORTAUDIO_LIBRARIES}
36 ${LIBSNDFILE_LIBRARY} 37 ${LIBSNDFILE_LIBRARY}
38 ${LIBXML2_LIBRARIES}
39)
40
41include_directories(
42 ${LIBXML2_INCLUDE_DIR}
37) 43)
38 44
39# include_directories(${SDL2_INCLUDE_DIR}) 45# include_directories(${SDL2_INCLUDE_DIR})
40set(CMAKE_BUILD_TYPE Debug) 46set(CMAKE_BUILD_TYPE Debug)
41add_executable(Aromatherapy src/main.cpp src/map.cpp src/renderer.cpp src/entity.cpp src/components.cpp src/game.cpp src/muxer.cpp) 47add_executable(Aromatherapy src/main.cpp src/map.cpp src/renderer.cpp src/entity.cpp src/components.cpp src/game.cpp src/muxer.cpp src/entityfactory.cpp)
42target_link_libraries(Aromatherapy ${ALL_LIBS}) 48target_link_libraries(Aromatherapy ${ALL_LIBS})
43install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 49install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})