summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-02-13 23:00:10 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-02-13 23:00:10 -0500
commit224645d1071c14b4829dbb3ae35870868fcff85a (patch)
treef84f540eee09315eb0a689c523946ffa03f4fea0 /CMakeLists.txt
parent3df19e45e737a1b9395a9a258e3263e444ebedd7 (diff)
downloadtherapy-224645d1071c14b4829dbb3ae35870868fcff85a.tar.gz
therapy-224645d1071c14b4829dbb3ae35870868fcff85a.tar.bz2
therapy-224645d1071c14b4829dbb3ae35870868fcff85a.zip
Fixed inconsistent rendering failure
The issue appears to have been caused by blending with unset alpha channels.

Also included the re-ordered player character sprite image.

The CMake file has been updated to include linking against some Apple libraries that are usually already included in GLFW3.

refs #1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 8b6ba2f..22bbc1a 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -17,13 +17,22 @@ find_package(portaudio REQUIRED)
17find_package(libsndfile REQUIRED) 17find_package(libsndfile REQUIRED)
18find_package(libxml2 REQUIRED) 18find_package(libxml2 REQUIRED)
19 19
20IF(APPLE)
21 FIND_LIBRARY(COCOA_LIBRARY Cocoa)
22 FIND_LIBRARY(CV_LIBRARY CoreVideo)
23 FIND_LIBRARY(IO_LIBRARY IOKit)
24 MARK_AS_ADVANCED (COCOA_LIBRARY CV_LIBRARY IO_LIBRARY)
25 SET(EXTRA_LIBS ${COCOA_LIBRARY} ${CV_LIBRARY} ${IO_LIBRARY})
26ENDIF (APPLE)
27
20set(ALL_LIBS 28set(ALL_LIBS
21 ${OPENGL_LIBRARIES} 29 ${OPENGL_gl_LIBRARY}
22 ${GLEW_LIBRARIES} 30 ${GLEW_LIBRARIES}
23 ${GLFW_LIBRARIES} 31 ${GLFW_LIBRARIES}
24 ${PORTAUDIO_LIBRARIES} 32 ${PORTAUDIO_LIBRARIES}
25 ${LIBSNDFILE_LIBRARY} 33 ${LIBSNDFILE_LIBRARY}
26 ${LIBXML2_LIBRARIES} 34 ${LIBXML2_LIBRARIES}
35 ${EXTRA_LIBS}
27) 36)
28 37
29include_directories( 38include_directories(