summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2021-03-05 20:50:51 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2021-03-05 20:50:51 -0500
commit1c462ef3780b33468ed93dde3ab6178765807ffe (patch)
tree6ee2f34ed3514c10d146c91b0e8e935cf9d1ccb6 /CMakeLists.txt
parent937875c4e1432b418f0f5051759e02c8d4c9ffa4 (diff)
downloadtanetane-1c462ef3780b33468ed93dde3ab6178765807ffe.tar.gz
tanetane-1c462ef3780b33468ed93dde3ab6178765807ffe.tar.bz2
tanetane-1c462ef3780b33468ed93dde3ab6178765807ffe.zip
Added MirrorSystem
This is really just for letting one sprite mirror another's movement and animation. I tried doing it in the BehaviourSystem, but you get stuttering if you do it earlier in the loop than the CharacterSystem, so I ended up having to make a new system just for this thing that will not happen very often.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index f42260e..5427efc 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -55,6 +55,7 @@ add_executable(tanetane
55 src/script_system.cpp 55 src/script_system.cpp
56 src/effect_system.cpp 56 src/effect_system.cpp
57 src/behaviour_system.cpp 57 src/behaviour_system.cpp
58 src/mirror_system.cpp
58) 59)
59 60
60set_property(TARGET tanetane PROPERTY CXX_STANDARD 17) 61set_property(TARGET tanetane PROPERTY CXX_STANDARD 17)