diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 348f7cc..323fb56 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,13 +1,16 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (manifesto) | 2 | project (manifesto) |
3 | 3 | ||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/libtwittercpp) | 4 | add_subdirectory(vendor/libtwittercpp) |
7 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
8 | 5 | ||
9 | include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include) | 6 | find_package(PkgConfig) |
7 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
8 | |||
9 | include_directories( | ||
10 | vendor/libtwittercpp/src | ||
11 | ${yaml-cpp_INCLUDE_DIRS}) | ||
12 | |||
10 | add_executable(manifesto manifesto.cpp) | 13 | add_executable(manifesto manifesto.cpp) |
11 | set_property(TARGET manifesto PROPERTY CXX_STANDARD 11) | 14 | set_property(TARGET manifesto PROPERTY CXX_STANDARD 11) |
12 | set_property(TARGET manifesto PROPERTY CXX_STANDARD_REQUIRED ON) | 15 | set_property(TARGET manifesto PROPERTY CXX_STANDARD_REQUIRED ON) |
13 | target_link_libraries(manifesto yaml-cpp twitter++) | 16 | target_link_libraries(manifesto ${yaml-cpp_LIBRARIES} twitter++) |