summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-03-25 17:59:08 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-03-25 17:59:08 -0400
commitee081426fe047eda0b44d98ec469b374145f0470 (patch)
treea13a17554903adad57102a05b844d80e769c22bc /CMakeLists.txt
parent3da97fc4dbdd5418999645b58fd73c6ab8f6f5f4 (diff)
downloadmanifesto-ee081426fe047eda0b44d98ec469b374145f0470.tar.gz
manifesto-ee081426fe047eda0b44d98ec469b374145f0470.tar.bz2
manifesto-ee081426fe047eda0b44d98ec469b374145f0470.zip
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 348f7cc..323fb56 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,13 +1,16 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (manifesto) 2project (manifesto)
3 3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/libtwittercpp) 4add_subdirectory(vendor/libtwittercpp)
7add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
8 5
9include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include) 6find_package(PkgConfig)
7pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
8
9include_directories(
10 vendor/libtwittercpp/src
11 ${yaml-cpp_INCLUDE_DIRS})
12
10add_executable(manifesto manifesto.cpp) 13add_executable(manifesto manifesto.cpp)
11set_property(TARGET manifesto PROPERTY CXX_STANDARD 11) 14set_property(TARGET manifesto PROPERTY CXX_STANDARD 11)
12set_property(TARGET manifesto PROPERTY CXX_STANDARD_REQUIRED ON) 15set_property(TARGET manifesto PROPERTY CXX_STANDARD_REQUIRED ON)
13target_link_libraries(manifesto yaml-cpp twitter++) 16target_link_libraries(manifesto ${yaml-cpp_LIBRARIES} twitter++)