about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..55a671b --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
1cmake_minimum_required (VERSION 3.1)
2project (lunatic)
3
4add_subdirectory(vendor/libtwittercpp)
5
6find_package(PkgConfig)
7pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
8
9include_directories(
10 vendor/libtwittercpp/src
11 ${yaml-cpp_INCLUDE_DIRS})
12
13add_executable(lunatic lunatic.cpp)
14set_property(TARGET lunatic PROPERTY CXX_STANDARD 11)
15set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON)
16target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} twitter++) \ No newline at end of file