diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-02-23 09:18:01 -0500 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-02-23 09:18:01 -0500 |
commit | b77ab7cb283e64fb8b23f4892115644e84596842 (patch) | |
tree | b5ecb460e5c10ce51df2594ba280e5d332e2cd2f /CMakeLists.txt | |
download | lunatic-b77ab7cb283e64fb8b23f4892115644e84596842.tar.gz lunatic-b77ab7cb283e64fb8b23f4892115644e84596842.tar.bz2 lunatic-b77ab7cb283e64fb8b23f4892115644e84596842.zip |
Created bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..55a671b --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,16 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (lunatic) | ||
3 | |||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | |||
6 | find_package(PkgConfig) | ||
7 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
8 | |||
9 | include_directories( | ||
10 | vendor/libtwittercpp/src | ||
11 | ${yaml-cpp_INCLUDE_DIRS}) | ||
12 | |||
13 | add_executable(lunatic lunatic.cpp) | ||
14 | set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) | ||
15 | set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) | ||
16 | target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} twitter++) \ No newline at end of file | ||