diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 11 |
1 files changed, 8 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 55a671b..00c0ad9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -5,12 +5,17 @@ add_subdirectory(vendor/libtwittercpp) | |||
5 | 5 | ||
6 | find_package(PkgConfig) | 6 | find_package(PkgConfig) |
7 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | 7 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) |
8 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
9 | pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED) | ||
8 | 10 | ||
9 | include_directories( | 11 | include_directories( |
10 | vendor/libtwittercpp/src | 12 | vendor/libtwittercpp/src |
11 | ${yaml-cpp_INCLUDE_DIRS}) | 13 | ${yaml-cpp_INCLUDE_DIRS} |
14 | ${GraphicsMagick_INCLUDE_DIRS}) | ||
12 | 15 | ||
13 | add_executable(lunatic lunatic.cpp) | 16 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) |
17 | |||
18 | add_executable(lunatic lunatic.cpp database.cpp) | ||
14 | set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) | 19 | set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) |
15 | set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) | 20 | set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) |
16 | target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} twitter++) \ No newline at end of file | 21 | target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file |