about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-03-01 16:03:16 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-03-01 16:03:16 -0500
commit473b327ceed3afb5e5683002b39fd9c1947cb25a (patch)
tree0dd2eac68605ad8cf34a2e2e54c6a44ad3ab14c1 /CMakeLists.txt
parentd85fed8541a9580e820a907d83a2184b020572ba (diff)
downloadlunatic-473b327ceed3afb5e5683002b39fd9c1947cb25a.tar.gz
lunatic-473b327ceed3afb5e5683002b39fd9c1947cb25a.tar.bz2
lunatic-473b327ceed3afb5e5683002b39fd9c1947cb25a.zip
Redesigned persistent data formta
This is the start of a project to add imagery to the bot's output. We began by rewriting the scraper to use a SQLite datafile instead of dumping achievement names to a text file. This allows storage of additional information about each achievement, and allows for more sophisticated scraping.

Profiles to be scraped can be added on the command line using the scraper script, instead of being specified in a config file. The scraper can conduct full or delta scrapes; in a delta scrape, only each profile's recent games are scraped, whereas they are all scraped in a full scrape.

When a game is scraped for the first time, images from the store page of that game are saved locally to be used by the bot. The bot has been altered to not use Twitter, and instead generate a pixelated image based on an image from the game of the chosen achievement. This is just for development purposes. It also crashes occasionally due to picking an achievement from a game that does not have any images saved.

Sprites of the moons from Odyssey have been included in the repository. A short message denoting their copyright is included.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 55a671b..00c0ad9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -5,12 +5,17 @@ add_subdirectory(vendor/libtwittercpp)
5 5
6find_package(PkgConfig) 6find_package(PkgConfig)
7pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) 7pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
8pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
9pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED)
8 10
9include_directories( 11include_directories(
10 vendor/libtwittercpp/src 12 vendor/libtwittercpp/src
11 ${yaml-cpp_INCLUDE_DIRS}) 13 ${yaml-cpp_INCLUDE_DIRS}
14 ${GraphicsMagick_INCLUDE_DIRS})
12 15
13add_executable(lunatic lunatic.cpp) 16link_directories(${GraphicsMagick_LIBRARY_DIRS})
17
18add_executable(lunatic lunatic.cpp database.cpp)
14set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) 19set_property(TARGET lunatic PROPERTY CXX_STANDARD 11)
15set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) 20set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON)
16target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} twitter++) \ No newline at end of file 21target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file