about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-04-12 18:40:52 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-04-12 18:40:52 -0400
commit891d57d200f55b91f80b6d3b4dd0c30479be6109 (patch)
treee87d1566ff941aa5003e1f937ccbb497fe1606a2 /CMakeLists.txt
downloadlibtwittercpp-891d57d200f55b91f80b6d3b4dd0c30479be6109.tar.gz
libtwittercpp-891d57d200f55b91f80b6d3b4dd0c30479be6109.tar.bz2
libtwittercpp-891d57d200f55b91f80b6d3b4dd0c30479be6109.zip
Added basic ability to tweet
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..7507e25 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
1cmake_minimum_required (VERSION 3.1)
2project (twitter++)
3
4include_directories(vendor/json/src)
5
6add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL)
7include_directories(vendor/liboauthcpp/include)
8
9add_subdirectory(vendor/curlcpp)
10include_directories(${CURLCPP_SOURCE_DIR}/include)
11
12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp)
13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11)
14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(twitter++ oauthcpp curlcpp)