diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..7507e25 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (twitter++) | ||
3 | |||
4 | include_directories(vendor/json/src) | ||
5 | |||
6 | add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL) | ||
7 | include_directories(vendor/liboauthcpp/include) | ||
8 | |||
9 | add_subdirectory(vendor/curlcpp) | ||
10 | include_directories(${CURLCPP_SOURCE_DIR}/include) | ||
11 | |||
12 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp) | ||
13 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) | ||
14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) | ||
15 | target_link_libraries(twitter++ oauthcpp curlcpp) | ||