summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index cc3fccd..d8ec06e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,21 +1,25 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (infinite) 2project (infinite)
3 3
4add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/verbly) 4add_subdirectory(vendor/verbly)
6 5
7find_package(PkgConfig) 6find_package(PkgConfig)
8pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 7pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
9pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) 8pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
9pkg_check_modules(mastodonpp mastodonpp REQUIRED)
10 10
11include_directories( 11include_directories(
12 ${GraphicsMagick_INCLUDE_DIRS} 12 ${GraphicsMagick_INCLUDE_DIRS}
13 vendor/verbly/lib 13 vendor/verbly/lib
14 vendor/libtwittercpp/src 14 vendor/json
15 ${mastodonpp_INCLUDE_DIRS}
15 ${yaml-cpp_INCLUDE_DIRS}) 16 ${yaml-cpp_INCLUDE_DIRS})
16 17
17link_directories(${GraphicsMagick_LIBRARY_DIRS}) 18link_directories(
19 ${GraphicsMagick_LIBRARY_DIRS}
20 ${mastodonpp_LIBRARY_DIRS})
21
18add_executable(infinite infinite.cpp color.cpp fractal.cpp matrix3x3.cpp vector3d.cpp tinyxml2.cpp triangle.cpp) 22add_executable(infinite infinite.cpp color.cpp fractal.cpp matrix3x3.cpp vector3d.cpp tinyxml2.cpp triangle.cpp)
19set_property(TARGET infinite PROPERTY CXX_STANDARD 11) 23set_property(TARGET infinite PROPERTY CXX_STANDARD 17)
20set_property(TARGET infinite PROPERTY CXX_STANDARD_REQUIRED ON) 24set_property(TARGET infinite PROPERTY CXX_STANDARD_REQUIRED ON)
21target_link_libraries(infinite ${GraphicsMagick_LIBRARIES} verbly ${yaml-cpp_LIBRARIES} twitter++) 25target_link_libraries(infinite ${GraphicsMagick_LIBRARIES} verbly ${yaml-cpp_LIBRARIES} ${mastodonpp_LIBRARIES})