diff options
author | Star Rauchenberger <fefferburbia@gmail.com> | 2022-11-15 14:12:26 -0500 |
---|---|---|
committer | Star Rauchenberger <fefferburbia@gmail.com> | 2022-11-15 14:12:26 -0500 |
commit | b668325558e75d97a6e99629c0a76e29235b8ac1 (patch) | |
tree | 7f411ac77666446b6a7e1b21126662d9304b26a9 /CMakeLists.txt | |
parent | d7fbb904d0dc70d1eada1dbb5f57f2ee9e5b399f (diff) | |
download | infinite-b668325558e75d97a6e99629c0a76e29235b8ac1.tar.gz infinite-b668325558e75d97a6e99629c0a76e29235b8ac1.tar.bz2 infinite-b668325558e75d97a6e99629c0a76e29235b8ac1.zip |
Bot posts to Mastodon now instead of Twitter
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 14 |
1 files changed, 9 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index cc3fccd..d8ec06e 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,21 +1,25 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | 1 | cmake_minimum_required (VERSION 3.1) |
2 | project (infinite) | 2 | project (infinite) |
3 | 3 | ||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/verbly) | 4 | add_subdirectory(vendor/verbly) |
6 | 5 | ||
7 | find_package(PkgConfig) | 6 | find_package(PkgConfig) |
8 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | 7 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) |
9 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | 8 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) |
9 | pkg_check_modules(mastodonpp mastodonpp REQUIRED) | ||
10 | 10 | ||
11 | include_directories( | 11 | include_directories( |
12 | ${GraphicsMagick_INCLUDE_DIRS} | 12 | ${GraphicsMagick_INCLUDE_DIRS} |
13 | vendor/verbly/lib | 13 | vendor/verbly/lib |
14 | vendor/libtwittercpp/src | 14 | vendor/json |
15 | ${mastodonpp_INCLUDE_DIRS} | ||
15 | ${yaml-cpp_INCLUDE_DIRS}) | 16 | ${yaml-cpp_INCLUDE_DIRS}) |
16 | 17 | ||
17 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) | 18 | link_directories( |
19 | ${GraphicsMagick_LIBRARY_DIRS} | ||
20 | ${mastodonpp_LIBRARY_DIRS}) | ||
21 | |||
18 | add_executable(infinite infinite.cpp color.cpp fractal.cpp matrix3x3.cpp vector3d.cpp tinyxml2.cpp triangle.cpp) | 22 | add_executable(infinite infinite.cpp color.cpp fractal.cpp matrix3x3.cpp vector3d.cpp tinyxml2.cpp triangle.cpp) |
19 | set_property(TARGET infinite PROPERTY CXX_STANDARD 11) | 23 | set_property(TARGET infinite PROPERTY CXX_STANDARD 17) |
20 | set_property(TARGET infinite PROPERTY CXX_STANDARD_REQUIRED ON) | 24 | set_property(TARGET infinite PROPERTY CXX_STANDARD_REQUIRED ON) |
21 | target_link_libraries(infinite ${GraphicsMagick_LIBRARIES} verbly ${yaml-cpp_LIBRARIES} twitter++) | 25 | target_link_libraries(infinite ${GraphicsMagick_LIBRARIES} verbly ${yaml-cpp_LIBRARIES} ${mastodonpp_LIBRARIES}) |