summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..3946a86 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
1cmake_minimum_required (VERSION 3.1)
2project (owo)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/verbly)
7add_subdirectory(vendor/libtwittercpp)
8add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
9
10include_directories(vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include)
11add_executable(owo owo.cpp)
12set_property(TARGET owo PROPERTY CXX_STANDARD 11)
13set_property(TARGET owo PROPERTY CXX_STANDARD_REQUIRED ON)
14target_link_libraries(owo verbly twitter++ yaml-cpp)