diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-11-05 03:39:00 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-11-05 03:39:00 -0400 |
commit | 51c0f61bde2799d8c1c903d95578b9d05778a22f (patch) | |
tree | af20170b9046f32e010518781ea0648a0d3287b4 /CMakeLists.txt | |
download | fruity-51c0f61bde2799d8c1c903d95578b9d05778a22f.tar.gz fruity-51c0f61bde2799d8c1c903d95578b9d05778a22f.tar.bz2 fruity-51c0f61bde2799d8c1c903d95578b9d05778a22f.zip |
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..3946a86 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,14 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (owo) | ||
3 | |||
4 | set(CMAKE_BUILD_TYPE Debug) | ||
5 | |||
6 | add_subdirectory(vendor/verbly) | ||
7 | add_subdirectory(vendor/libtwittercpp) | ||
8 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
9 | |||
10 | include_directories(vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include) | ||
11 | add_executable(owo owo.cpp) | ||
12 | set_property(TARGET owo PROPERTY CXX_STANDARD 11) | ||
13 | set_property(TARGET owo PROPERTY CXX_STANDARD_REQUIRED ON) | ||
14 | target_link_libraries(owo verbly twitter++ yaml-cpp) | ||