summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..8266a02 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
1cmake_minimum_required (VERSION 3.1)
2project (father)
3
4add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/verbly)
6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
7
8include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/verbly/lib)
9add_executable(father father.cpp)
10set_property(TARGET father PROPERTY CXX_STANDARD 11)
11set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON)
12target_link_libraries(father verbly yaml-cpp twitter++)
13