diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-02-19 15:36:40 -0500 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-02-19 15:36:40 -0500 |
commit | 95b7ae535c0b005466e34096f5ce427046a403d2 (patch) | |
tree | 806d031c7894322c56d2457d64a51f893b3c38ba /CMakeLists.txt | |
download | father-95b7ae535c0b005466e34096f5ce427046a403d2.tar.gz father-95b7ae535c0b005466e34096f5ce427046a403d2.tar.bz2 father-95b7ae535c0b005466e34096f5ce427046a403d2.zip |
Created bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..8266a02 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,13 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (father) | ||
3 | |||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/verbly) | ||
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | |||
8 | include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/verbly/lib) | ||
9 | add_executable(father father.cpp) | ||
10 | set_property(TARGET father PROPERTY CXX_STANDARD 11) | ||
11 | set_property(TARGET father PROPERTY CXX_STANDARD_REQUIRED ON) | ||
12 | target_link_libraries(father verbly yaml-cpp twitter++) | ||
13 | |||