diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 12 |
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 793ae7e..0a0a209 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -3,10 +3,16 @@ project (blessed) | |||
3 | 3 | ||
4 | add_subdirectory(vendor/libtwittercpp) | 4 | add_subdirectory(vendor/libtwittercpp) |
5 | add_subdirectory(vendor/verbly) | 5 | add_subdirectory(vendor/verbly) |
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | 6 | ||
8 | include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) | 7 | find_package(PkgConfig) |
8 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
9 | |||
10 | include_directories( | ||
11 | vendor/libtwittercpp/src | ||
12 | vendor/verbly/lib | ||
13 | ${yaml-cpp_INCLUDE_DIRS}) | ||
14 | |||
9 | add_executable(blessed blessed.cpp) | 15 | add_executable(blessed blessed.cpp) |
10 | set_property(TARGET blessed PROPERTY CXX_STANDARD 11) | 16 | set_property(TARGET blessed PROPERTY CXX_STANDARD 11) |
11 | set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) | 17 | set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) |
12 | target_link_libraries(blessed twitter++ yaml-cpp verbly) | 18 | target_link_libraries(blessed twitter++ ${yaml-cpp_LIBRARIES} verbly) |