about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-08-04 19:25:22 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-08-04 19:25:22 -0400
commitcb7166d7bccc4b16292c9e1359b9bc091afad716 (patch)
treefc6b51e8e7e567b074db86fa51aa4a7f6a585779 /CMakeLists.txt
parent2a40a70aa8f9c464f9d91314c6c7265e1b6a1049 (diff)
downloadblessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.tar.gz
blessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.tar.bz2
blessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.zip
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 793ae7e..0a0a209 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -3,10 +3,16 @@ project (blessed)
3 3
4add_subdirectory(vendor/libtwittercpp) 4add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
7 6
8include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) 7find_package(PkgConfig)
8pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
9
10include_directories(
11 vendor/libtwittercpp/src
12 vendor/verbly/lib
13 ${yaml-cpp_INCLUDE_DIRS})
14
9add_executable(blessed blessed.cpp) 15add_executable(blessed blessed.cpp)
10set_property(TARGET blessed PROPERTY CXX_STANDARD 11) 16set_property(TARGET blessed PROPERTY CXX_STANDARD 11)
11set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) 17set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON)
12target_link_libraries(blessed twitter++ yaml-cpp verbly) 18target_link_libraries(blessed twitter++ ${yaml-cpp_LIBRARIES} verbly)