diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-08-04 19:25:22 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-08-04 19:25:22 -0400 |
commit | cb7166d7bccc4b16292c9e1359b9bc091afad716 (patch) | |
tree | fc6b51e8e7e567b074db86fa51aa4a7f6a585779 /CMakeLists.txt | |
parent | 2a40a70aa8f9c464f9d91314c6c7265e1b6a1049 (diff) | |
download | blessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.tar.gz blessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.tar.bz2 blessed-cb7166d7bccc4b16292c9e1359b9bc091afad716.zip |
Removed yaml-cpp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 12 |
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 793ae7e..0a0a209 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -3,10 +3,16 @@ project (blessed) | |||
3 | 3 | ||
4 | add_subdirectory(vendor/libtwittercpp) | 4 | add_subdirectory(vendor/libtwittercpp) |
5 | add_subdirectory(vendor/verbly) | 5 | add_subdirectory(vendor/verbly) |
6 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
7 | 6 | ||
8 | include_directories(vendor/libtwittercpp/src vendor/verbly/lib vendor/yaml-cpp/include) | 7 | find_package(PkgConfig) |
8 | pkg_check_modules(yaml-cpp yaml-cpp REQUIRED) | ||
9 | |||
10 | include_directories( | ||
11 | vendor/libtwittercpp/src | ||
12 | vendor/verbly/lib | ||
13 | ${yaml-cpp_INCLUDE_DIRS}) | ||
14 | |||
9 | add_executable(blessed blessed.cpp) | 15 | add_executable(blessed blessed.cpp) |
10 | set_property(TARGET blessed PROPERTY CXX_STANDARD 11) | 16 | set_property(TARGET blessed PROPERTY CXX_STANDARD 11) |
11 | set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) | 17 | set_property(TARGET blessed PROPERTY CXX_STANDARD_REQUIRED ON) |
12 | target_link_libraries(blessed twitter++ yaml-cpp verbly) | 18 | target_link_libraries(blessed twitter++ ${yaml-cpp_LIBRARIES} verbly) |