about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index c77e9fa..944d769 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,11 +1,19 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (yandere) 2project (yandere)
3 3
4add_subdirectory(vendor/mastodonpp) 4find_package(PkgConfig)
5add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) 5pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
6pkg_check_modules(mastodonpp mastodonpp REQUIRED)
7
8include_directories(
9 ${mastodonpp_INCLUDE_DIRS}
10 ${yaml-cpp_INCLUDE_DIRS})
11
12link_directories(
13 ${mastodonpp_LIBRARY_DIRS}
14 ${yaml-cpp_LIBRARY_DIRS})
6 15
7include_directories(vendor/mastodonpp/include vendor/yaml-cpp/include)
8add_executable(yandere yandere.cpp) 16add_executable(yandere yandere.cpp)
9set_property(TARGET yandere PROPERTY CXX_STANDARD 17) 17set_property(TARGET yandere PROPERTY CXX_STANDARD 17)
10set_property(TARGET yandere PROPERTY CXX_STANDARD_REQUIRED ON) 18set_property(TARGET yandere PROPERTY CXX_STANDARD_REQUIRED ON)
11target_link_libraries(yandere yaml-cpp mastodonpp) 19target_link_libraries(yandere ${mastodonpp_LIBRARIES} ${yaml-cpp_LIBRARIES})