about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-03-26 09:42:45 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-03-26 09:42:45 -0400
commitce7f42f1f3a45b9167a9cc4e85e1bc4488013c70 (patch)
treecf5d20927bc65a3a70303251ded0fb78072c642b /CMakeLists.txt
downloadyandere-ce7f42f1f3a45b9167a9cc4e85e1bc4488013c70.tar.gz
yandere-ce7f42f1f3a45b9167a9cc4e85e1bc4488013c70.tar.bz2
yandere-ce7f42f1f3a45b9167a9cc4e85e1bc4488013c70.zip
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..9508ca5 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
1cmake_minimum_required (VERSION 2.6)
2project (chemist)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/twitcurl/libtwitcurl)
7add_subdirectory(vendor/verbly)
8
9find_package(PkgConfig)
10pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
11pkg_check_modules(sqlite3 sqlite3 REQUIRED)
12
13include_directories(vendor/twitcurl/libtwitcurl ${sqlite3_INCLUDE_DIR} vendor/verbly/lib)
14add_executable(chemist chemist.cpp)
15set_property(TARGET chemist PROPERTY CXX_STANDARD 11)
16set_property(TARGET chemist PROPERTY CXX_STANDARD_REQUIRED ON)
17target_link_libraries(chemist verbly ${sqlite3_LIBRARIES} ${YamlCpp_LIBRARIES} twitcurl curl)