diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-10-07 15:09:37 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2018-10-07 15:09:37 -0400 |
commit | a3056929ea8381884655a46f80b4c0e1fdb66341 (patch) | |
tree | d107fc082e54ee255b03835657421cff43f7a59a /CMakeLists.txt | |
download | wizard-a3056929ea8381884655a46f80b4c0e1fdb66341.tar.gz wizard-a3056929ea8381884655a46f80b4c0e1fdb66341.tar.bz2 wizard-a3056929ea8381884655a46f80b4c0e1fdb66341.zip |
Working prototype
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..f6380ee --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,25 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (wizard) | ||
3 | |||
4 | find_package(PkgConfig) | ||
5 | pkg_check_modules(tesseract tesseract REQUIRED) | ||
6 | pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) | ||
7 | |||
8 | add_subdirectory(vendor/curlcpp) | ||
9 | |||
10 | include_directories( | ||
11 | vendor/json | ||
12 | vendor/hkutil | ||
13 | ${tesseract_INCLUDE_DIRS} | ||
14 | ${GraphicsMagick_INCLUDE_DIRS} | ||
15 | ${CURLCPP_SOURCE_DIR}/include) | ||
16 | |||
17 | add_executable(wizard wizard.cpp) | ||
18 | set_property(TARGET wizard PROPERTY CXX_STANDARD 14) | ||
19 | set_property(TARGET wizard PROPERTY CXX_STANDARD_REQUIRED ON) | ||
20 | target_link_libraries( | ||
21 | wizard | ||
22 | ${tesseract_LIBRARIES} | ||
23 | ${GraphicsMagick_LIBRARIES} | ||
24 | lept | ||
25 | curlcpp) | ||