summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 14278cb..12d2551 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -56,22 +56,18 @@ link_directories(
56set(CMAKE_BUILD_TYPE Debug) 56set(CMAKE_BUILD_TYPE Debug)
57add_executable(Aromatherapy 57add_executable(Aromatherapy
58 src/main.cpp 58 src/main.cpp
59 src/map.cpp
60 src/renderer.cpp 59 src/renderer.cpp
61 src/entity.cpp
62 src/game.cpp
63 src/muxer.cpp 60 src/muxer.cpp
64 src/entityfactory.cpp 61 src/entity_manager.cpp
65 src/world.cpp 62 src/game.cpp
66 src/components/ai.cpp 63 src/components/transformable.cpp
67 src/components/map_collision.cpp 64 src/components/droppable.cpp
68 src/components/map_render.cpp 65 src/components/controllable.cpp
69 src/components/physics_body.cpp 66 src/components/ponderable.cpp
70 src/components/player_physics.cpp 67 src/components/animatable.cpp
71 src/components/player_sprite.cpp 68 src/systems/rendering.cpp
72 src/components/simple_collider.cpp 69 src/systems/controlling.cpp
73 src/components/static_image.cpp 70 src/systems/pondering.cpp
74 src/components/user_movement.cpp
75) 71)
76target_link_libraries(Aromatherapy ${ALL_LIBS}) 72target_link_libraries(Aromatherapy ${ALL_LIBS})
77install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR}) 73install(TARGETS Aromatherapy RUNTIME DESTINATION ${BIN_DIR})