summary refs log tree commit diff stats
path: root/tools/mapedit/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2015-03-17 23:53:55 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2015-03-17 23:53:55 -0400
commitf732cdaf7374fde737b503ec6966fb8cd8f4c32b (patch)
treef7fa3122f30ee98a5984cf7e5fb0260c6c6c1148 /tools/mapedit/CMakeLists.txt
parentb2ad90fef0e31a1d8635b817940d9bf71320b588 (diff)
downloadtherapy-f732cdaf7374fde737b503ec6966fb8cd8f4c32b.tar.gz
therapy-f732cdaf7374fde737b503ec6966fb8cd8f4c32b.tar.bz2
therapy-f732cdaf7374fde737b503ec6966fb8cd8f4c32b.zip
Map editor can now define actions to occur when the player goes off a specified edge of the map
Diffstat (limited to 'tools/mapedit/CMakeLists.txt')
-rw-r--r--tools/mapedit/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/mapedit/CMakeLists.txt b/tools/mapedit/CMakeLists.txt index ca44fc5..b225834 100644 --- a/tools/mapedit/CMakeLists.txt +++ b/tools/mapedit/CMakeLists.txt
@@ -10,7 +10,7 @@ set(BIN_DIR ${AromatherapyMapEditor_SOURCE_DIR}/bin)
10# selecting the build mode in their IDE 10# selecting the build mode in their IDE
11if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" OR ${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang") 11if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" OR ${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
12 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -pedantic -std=c++11") 12 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -pedantic -std=c++11")
13 set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG} -g") 13 set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_DEBUG} -g -O0")
14 set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE} -O2") 14 set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE} -O2")
15elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL "MSVC") 15elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL "MSVC")
16 if (CMAKE_CXX_FLAGS MATCHES "/W[0-4]") 16 if (CMAKE_CXX_FLAGS MATCHES "/W[0-4]")
@@ -46,6 +46,7 @@ add_executable(AromatherapyMapEditor
46 src/object.cpp 46 src/object.cpp
47 src/world.cpp 47 src/world.cpp
48 src/undo.cpp 48 src/undo.cpp
49 src/mapselect_combo.cpp
49) 50)
50target_link_libraries(AromatherapyMapEditor ${ALL_LIBS}) 51target_link_libraries(AromatherapyMapEditor ${ALL_LIBS})
51install(TARGETS AromatherapyMapEditor RUNTIME DESTINATION ${BIN_DIR}) 52install(TARGETS AromatherapyMapEditor RUNTIME DESTINATION ${BIN_DIR})