summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..52d0ce5 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,28 @@
1cmake_minimum_required (VERSION 3.1)
2project (tanetane)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6# Get dependencies.
7find_package(SDL2 REQUIRED)
8
9set(ALL_LIBS
10 ${SDL2_LIBRARY}
11)
12
13include_directories(
14 ${SDL2_INCLUDE_DIR}
15 src
16)
17
18link_directories(
19 ${SDL2_LIBRARY_DIRS}
20)
21
22add_executable(tanetane
23 src/main.cpp
24)
25
26set_property(TARGET tanetane PROPERTY CXX_STANDARD 17)
27set_property(TARGET tanetane PROPERTY CXX_STANDARD_REQUIRED ON)
28target_link_libraries(tanetane ${ALL_LIBS})