summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2021-01-30 04:46:44 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2021-01-30 04:46:44 -0500
commitd92c7970df0d2e0a0c3f84037640336102c084a6 (patch)
tree162f27ff353ca1ae7a5df78a651c93e2e5865aac /CMakeLists.txt
parent2ff08dfdbb94d059a2c92da56c0266d38854df8a (diff)
downloadtanetane-d92c7970df0d2e0a0c3f84037640336102c084a6.tar.gz
tanetane-d92c7970df0d2e0a0c3f84037640336102c084a6.tar.bz2
tanetane-d92c7970df0d2e0a0c3f84037640336102c084a6.zip
Imported renderer stuff from Ether
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 52d0ce5..55237fa 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -3,15 +3,21 @@ project (tanetane)
3 3
4set(CMAKE_BUILD_TYPE Debug) 4set(CMAKE_BUILD_TYPE Debug)
5 5
6# Set directory to look for package helpers.
7set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${tanetane_SOURCE_DIR}/cmake")
8
6# Get dependencies. 9# Get dependencies.
7find_package(SDL2 REQUIRED) 10find_package(SDL2 REQUIRED)
11find_package(SDL2_Image REQUIRED)
8 12
9set(ALL_LIBS 13set(ALL_LIBS
10 ${SDL2_LIBRARY} 14 ${SDL2_LIBRARY}
15 ${SDL2_IMAGE_LIBRARIES}
11) 16)
12 17
13include_directories( 18include_directories(
14 ${SDL2_INCLUDE_DIR} 19 ${SDL2_INCLUDE_DIR}
20 ${SDL2_IMAGE_INCLUDE_DIRS}
15 src 21 src
16) 22)
17 23
@@ -21,6 +27,7 @@ link_directories(
21 27
22add_executable(tanetane 28add_executable(tanetane
23 src/main.cpp 29 src/main.cpp
30 src/renderer.cpp
24) 31)
25 32
26set_property(TARGET tanetane PROPERTY CXX_STANDARD 17) 33set_property(TARGET tanetane PROPERTY CXX_STANDARD 17)