about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac deleted file mode 100644 index 31cf8b9..0000000 --- a/configure.ac +++ /dev/null
@@ -1,35 +0,0 @@
1AC_INIT(rawr-ebooks, version-1.0)
2AC_PREREQ([2.59])
3AM_INIT_AUTOMAKE([1.10 no-define foreign])
4AC_PROG_CXX
5AC_CONFIG_FILES([Makefile])
6
7# Get libtwitcurl library and include locations
8AC_ARG_WITH([libtwitcurl-include-path],
9 [AS_HELP_STRING([--with-libtwitcurl-include-path],
10 [location of the libtwitcurl headers, defaults to /usr/include])],
11 [LIBTWITCURL_CFLAGS="-I$withval"],
12 [LIBTWITCURL_CFLAGS=''])
13AC_SUBST([LIBTWITCURL_CFLAGS])
14
15AC_ARG_WITH([libtwitcurl-lib-path],
16 [AS_HELP_STRING([--with-libtwitcurl-lib-path], [location of the libtwitcurl libraries])],
17 [LIBTWITCURL_LIBS="-L$withval -llibtwitcurl"],
18 [LIBTWITCURL_LIBS='-ltwitcurl'])
19AC_SUBST([LIBTWITCURL_LIBS])
20
21# Get yaml-cpp library and include locations
22AC_ARG_WITH([yamlcpp-include-path],
23 [AS_HELP_STRING([--with-yamlcpp-include-path],
24 [location of the yamlcpp headers, defaults to /usr/include])],
25 [YAML_CFLAGS="-I$withval"],
26 [YAML_CFLAGS=''])
27AC_SUBST([YAML_CFLAGS])
28
29AC_ARG_WITH([yamlcpp-lib-path],
30 [AS_HELP_STRING([--with-yamlcpp-lib-path], [location of the yamlcpp libraries])],
31 [YAML_LIBS="-L$withval -lyaml-cpp"],
32 [YAML_LIBS='-lyaml-cpp'])
33AC_SUBST([YAML_LIBS])
34
35AC_OUTPUT