about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-02-28 18:21:01 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-02-28 18:21:01 -0500
commit717e6c62020f2408c3a72ab87e0cba410acc17e4 (patch)
treeecba36d6d392e5fe61ff982ccba7e81e8cfae745 /CMakeLists.txt
parentb228eb802b3c468bc7a7b905a0b771ba24679bab (diff)
downloadrawr-ebooks-717e6c62020f2408c3a72ab87e0cba410acc17e4.tar.gz
rawr-ebooks-717e6c62020f2408c3a72ab87e0cba410acc17e4.tar.bz2
rawr-ebooks-717e6c62020f2408c3a72ab87e0cba410acc17e4.zip
Added yaml-cpp as a vendor submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index c0a0d69..f43e46c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -2,19 +2,22 @@ cmake_minimum_required (VERSION 2.6)
2project (rawr-ebooks) 2project (rawr-ebooks)
3 3
4find_package(PkgConfig) 4find_package(PkgConfig)
5pkg_check_modules(YamlCpp yaml-cpp)
6pkg_check_modules(Curl libcurl) 5pkg_check_modules(Curl libcurl)
7 6
8if (YamlCpp_FOUND AND Curl_FOUND) 7if (Curl_FOUND)
9 add_subdirectory(vendor/twitcurl/libtwitcurl) 8 add_subdirectory(vendor/twitcurl/libtwitcurl)
10 include_directories(vendor/twitcurl/libtwitcurl) 9 include_directories(vendor/twitcurl/libtwitcurl)
10
11 add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
12 include_directories(vendor/yaml-cpp/include)
13
11 add_executable(rawr-ebooks ebooks.cpp kgramstats.cpp freevars.cpp histogram.cpp prefix_search.cpp) 14 add_executable(rawr-ebooks ebooks.cpp kgramstats.cpp freevars.cpp histogram.cpp prefix_search.cpp)
12 set_property(TARGET rawr-ebooks PROPERTY CXX_STANDARD 11) 15 set_property(TARGET rawr-ebooks PROPERTY CXX_STANDARD 11)
13 set_property(TARGET rawr-ebooks PROPERTY CXX_STANDARD_REQUIRED ON) 16 set_property(TARGET rawr-ebooks PROPERTY CXX_STANDARD_REQUIRED ON)
14 target_link_libraries(rawr-ebooks ${YamlCpp_LIBRARIES} twitcurl ${Curl_LIBRARIES} aspell) 17 target_link_libraries(rawr-ebooks yaml-cpp twitcurl ${Curl_LIBRARIES} aspell)
15else (YamlCpp_FOUND AND Curl_FOUND) 18else (Curl_FOUND)
16 message(STATUS "rawr-ebooks requires yaml-cpp and twitcurl; without these, we will only make rawr-gen") 19 message(STATUS "rawr-ebooks requires yaml-cpp and twitcurl; without these, we will only make rawr-gen")
17endif (YamlCpp_FOUND AND Curl_FOUND) 20endif (Curl_FOUND)
18 21
19add_executable(rawr-gen gen.cpp kgramstats.cpp freevars.cpp histogram.cpp prefix_search.cpp) 22add_executable(rawr-gen gen.cpp kgramstats.cpp freevars.cpp histogram.cpp prefix_search.cpp)
20set_property(TARGET rawr-gen PROPERTY CXX_STANDARD 11) 23set_property(TARGET rawr-gen PROPERTY CXX_STANDARD 11)