diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-09-19 09:59:17 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2017-09-19 09:59:17 -0400 |
commit | afbe0bd9678619fe1b022075615229c875c0b98a (patch) | |
tree | c08a5524d7f83c14013d3f660e575fdd9e51750f /CMakeLists.txt | |
download | pokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.tar.gz pokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.tar.bz2 pokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.zip |
Created bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..8800bbc --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,11 @@ | |||
1 | cmake_minimum_required (VERSION 3.1) | ||
2 | project (pokepronouns) | ||
3 | |||
4 | add_subdirectory(vendor/libtwittercpp) | ||
5 | add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) | ||
6 | |||
7 | include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include) | ||
8 | add_executable(pokepronouns pokepronouns.cpp) | ||
9 | set_property(TARGET pokepronouns PROPERTY CXX_STANDARD 11) | ||
10 | set_property(TARGET pokepronouns PROPERTY CXX_STANDARD_REQUIRED ON) | ||
11 | target_link_libraries(pokepronouns yaml-cpp twitter++) | ||