summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2017-09-19 09:59:17 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2017-09-19 09:59:17 -0400
commitafbe0bd9678619fe1b022075615229c875c0b98a (patch)
treec08a5524d7f83c14013d3f660e575fdd9e51750f /CMakeLists.txt
downloadpokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.tar.gz
pokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.tar.bz2
pokepronouns-afbe0bd9678619fe1b022075615229c875c0b98a.zip
Created bot
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..8800bbc --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
1cmake_minimum_required (VERSION 3.1)
2project (pokepronouns)
3
4add_subdirectory(vendor/libtwittercpp)
5add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
6
7include_directories(vendor/libtwittercpp/src vendor/yaml-cpp/include)
8add_executable(pokepronouns pokepronouns.cpp)
9set_property(TARGET pokepronouns PROPERTY CXX_STANDARD 11)
10set_property(TARGET pokepronouns PROPERTY CXX_STANDARD_REQUIRED ON)
11target_link_libraries(pokepronouns yaml-cpp twitter++)