about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-03-09 09:37:28 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-03-09 09:37:28 -0500
commitbdd0f853177dce9e67c3268bec0b77094ef30fa6 (patch)
tree5d0a1df2167d10e8cac80b207530f353ff033c2d /CMakeLists.txt
downloadnancy-bdd0f853177dce9e67c3268bec0b77094ef30fa6.tar.gz
nancy-bdd0f853177dce9e67c3268bec0b77094ef30fa6.tar.bz2
nancy-bdd0f853177dce9e67c3268bec0b77094ef30fa6.zip
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..307a777 --- /dev/null +++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
1cmake_minimum_required (VERSION 2.6)
2project (nancy)
3
4set(CMAKE_BUILD_TYPE Debug)
5
6add_subdirectory(vendor/twitcurl/libtwitcurl)
7
8set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
9
10find_package(PkgConfig)
11pkg_check_modules(YamlCpp yaml-cpp REQUIRED)
12find_package(Mysql REQUIRED)
13
14include_directories(vendor/twitcurl/libtwitcurl ${MYSQL_INCLUDE_DIR})
15add_executable(nancy nancy.cpp)
16set_property(TARGET nancy PROPERTY CXX_STANDARD 11)
17set_property(TARGET nancy PROPERTY CXX_STANDARD_REQUIRED ON)
18target_link_libraries(nancy ${YamlCpp_LIBRARIES} ${MYSQL_LIBRARIES} twitcurl curl)