about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 16:49:48 -0500
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-11-27 16:49:48 -0500
commit4aedd681a0ddf511f3bb4254e2960fce7f400b04 (patch)
treeeaf93841c277e38054e5df8b255fb5f53c4c3be4 /CMakeLists.txt
parentb5628b64e540a5a5088338b6b839e99bb40a85d8 (diff)
downloadnancy-4aedd681a0ddf511f3bb4254e2960fce7f400b04.tar.gz
nancy-4aedd681a0ddf511f3bb4254e2960fce7f400b04.tar.bz2
nancy-4aedd681a0ddf511f3bb4254e2960fce7f400b04.zip
Switched from twitcurl to libtwitter++
Also updated verbly to remove dependence on json submodule, replaced
uses of the C random API with the C++ random API, and replaced the
UNIX-dependent sleep call with the sleep functionality in the C++
standard library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index d57c96a..088e566 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,17 +1,12 @@
1cmake_minimum_required (VERSION 2.6) 1cmake_minimum_required (VERSION 3.1)
2project (nancy) 2project (nancy)
3 3
4set(CMAKE_BUILD_TYPE Debug) 4add_subdirectory(vendor/libtwittercpp)
5
6add_subdirectory(vendor/twitcurl/libtwitcurl)
7add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
8add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL) 6add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
9 7
10find_package(PkgConfig) 8include_directories(vendor/yaml-cpp/include vendor/libtwittercpp/src vendor/verbly/lib)
11pkg_check_modules(sqlite3 sqlite3 REQUIRED)
12
13include_directories(vendor/yaml-cpp/include vendor/twitcurl/libtwitcurl vendor/verbly/lib)
14add_executable(nancy nancy.cpp) 9add_executable(nancy nancy.cpp)
15set_property(TARGET nancy PROPERTY CXX_STANDARD 11) 10set_property(TARGET nancy PROPERTY CXX_STANDARD 11)
16set_property(TARGET nancy PROPERTY CXX_STANDARD_REQUIRED ON) 11set_property(TARGET nancy PROPERTY CXX_STANDARD_REQUIRED ON)
17target_link_libraries(nancy yaml-cpp twitcurl curl verbly ${sqlite3_LIBRARIES}) 12target_link_libraries(nancy yaml-cpp twitter++ verbly)