summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac new file mode 100644 index 0000000..f311aa6 --- /dev/null +++ b/configure.ac
@@ -0,0 +1,44 @@
1AC_INIT(mazeoflife, version-2.0)
2AC_PREREQ([2.59])
3AM_INIT_AUTOMAKE([1.10 no-define foreign])
4AC_PROG_CXX
5AC_CONFIG_FILES([Makefile])
6
7dnl Check for SDL
8SDL_VERSION=1.2.0
9AM_PATH_SDL($SDL_VERSION,
10 :,
11 AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
12)
13CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
14LIBS="$LIBS $SDL_LIBS"
15
16dnl Check for SDL_ttf
17AC_ARG_WITH([sdl-ttf-include-path],
18 [AS_HELP_STRING([--with-sdl-ttf-include-path],
19 [location of the SDL_ttf headers, defaults to /usr/include/SDL])],
20 [SDLTTF_CXXFLAGS="-I$withval"],
21 [SDLTTF_CXXFLAGS="-I/usr/include/SDL"])
22AC_SUBST([SDLTTF_CXXFLAGS])
23
24AC_ARG_WITH([sdl-ttf-lib-path],
25 [AS_HELP_STRING([--with-sdl-ttf-lib-path], [location of the SDL_ttf library])],
26 [SDLTTF_LIBS="-L$withval -lsdl_ttf"],
27 [SDLTTF_LIBS="-lsdl_ttf"])
28AC_SUBST([SDLTTF_LIBS])
29
30dnl Check for SDL_net
31AC_ARG_WITH([sdl-net-include-path],
32 [AS_HELP_STRING([--with-sdl-net-include-path],
33 [location of the SDL_net headers, defaults to /usr/include/SDL])],
34 [SDLNET_CXXFLAGS="-I$withval"],
35 [SDLNET_CXXFLAGS="-I/usr/include/SDL"])
36AC_SUBST([SDLNET_CXXFLAGS])
37
38AC_ARG_WITH([sdl-net-lib-path],
39 [AS_HELP_STRING([--with-sdl-net-lib-path], [location of the SDL_net library])],
40 [SDLNET_LIBS="-L$withval -lsdl_net"],
41 [SDLNET_LIBS="-lsdl_net"])
42AC_SUBST([SDLNET_LIBS])
43
44AC_OUTPUT \ No newline at end of file