summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac deleted file mode 100644 index a16f206..0000000 --- a/configure.ac +++ /dev/null
@@ -1,28 +0,0 @@
1# -*- Autoconf -*-
2# Process this file with autoconf to produce a configure script.
3
4AC_PREREQ([2.63])
5AC_INIT([Maze Of Life], [2.0], [BUG-REPORT-ADDRESS])
6AM_INIT_AUTOMAKE
7AC_CONFIG_SRCDIR([src/mazeoflife.cpp])
8AC_CONFIG_HEADERS([config.h])
9
10# Checks for programs.
11AC_PROG_CXX
12AC_PROG_CC
13
14# Checks for libraries.
15PKG_CHECK_MODULES([SDL], [sdl >= 1.2])
16CXXFLAGS="$SDL_CFLAGS $CXXFLAGS"
17LDFLAGS="$SDL_LIBS"
18
19# Checks for header files.
20
21# Checks for typedefs, structures, and compiler characteristics.
22AC_HEADER_STDBOOL
23
24# Checks for library functions.
25AC_CHECK_FUNCS([atexit])
26
27AC_CONFIG_FILES([Makefile src/Makefile])
28AC_OUTPUT