diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 00c0ad9..d9a289c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -11,11 +11,12 @@ pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED) | |||
11 | include_directories( | 11 | include_directories( |
12 | vendor/libtwittercpp/src | 12 | vendor/libtwittercpp/src |
13 | ${yaml-cpp_INCLUDE_DIRS} | 13 | ${yaml-cpp_INCLUDE_DIRS} |
14 | ${GraphicsMagick_INCLUDE_DIRS}) | 14 | ${GraphicsMagick_INCLUDE_DIRS} |
15 | vendor/hkutil) | ||
15 | 16 | ||
16 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) | 17 | link_directories(${GraphicsMagick_LIBRARY_DIRS}) |
17 | 18 | ||
18 | add_executable(lunatic lunatic.cpp database.cpp) | 19 | add_executable(lunatic lunatic.cpp) |
19 | set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) | 20 | set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) |
20 | set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) | 21 | set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) |
21 | target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file | 22 | target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file |