about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-03-28 21:12:17 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-03-28 21:12:17 -0400
commit54c8a082aa513cb10860e16a74b7f2e7ae638b2b (patch)
treee4963c0f6b5212dcb98798bd2b7a266d59dca69e /CMakeLists.txt
parent6499b28df7b90025b5045cb343a110a1bdb6dfbe (diff)
downloadlunatic-54c8a082aa513cb10860e16a74b7f2e7ae638b2b.tar.gz
lunatic-54c8a082aa513cb10860e16a74b7f2e7ae638b2b.tar.bz2
lunatic-54c8a082aa513cb10860e16a74b7f2e7ae638b2b.zip
Migrated to hkutil
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 00c0ad9..d9a289c 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -11,11 +11,12 @@ pkg_check_modules(sqlite3 sqlite3>=3.8.3 REQUIRED)
11include_directories( 11include_directories(
12 vendor/libtwittercpp/src 12 vendor/libtwittercpp/src
13 ${yaml-cpp_INCLUDE_DIRS} 13 ${yaml-cpp_INCLUDE_DIRS}
14 ${GraphicsMagick_INCLUDE_DIRS}) 14 ${GraphicsMagick_INCLUDE_DIRS}
15 vendor/hkutil)
15 16
16link_directories(${GraphicsMagick_LIBRARY_DIRS}) 17link_directories(${GraphicsMagick_LIBRARY_DIRS})
17 18
18add_executable(lunatic lunatic.cpp database.cpp) 19add_executable(lunatic lunatic.cpp)
19set_property(TARGET lunatic PROPERTY CXX_STANDARD 11) 20set_property(TARGET lunatic PROPERTY CXX_STANDARD 11)
20set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON) 21set_property(TARGET lunatic PROPERTY CXX_STANDARD_REQUIRED ON)
21target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file 22target_link_libraries(lunatic ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} ${sqlite3_LIBRARIES} twitter++) \ No newline at end of file