about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 7507e25..9f290c9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ include_directories(vendor/liboauthcpp/include)
9add_subdirectory(vendor/curlcpp) 9add_subdirectory(vendor/curlcpp)
10include_directories(${CURLCPP_SOURCE_DIR}/include) 10include_directories(${CURLCPP_SOURCE_DIR}/include)
11 11
12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp) 12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp)
13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) 13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11)
14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) 14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(twitter++ oauthcpp curlcpp) 15target_link_libraries(twitter++ oauthcpp curlcpp)