about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-04-13 11:24:24 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-04-13 11:24:24 -0400
commit7e85b35d7d1714e3f85434b891a1050ad584e337 (patch)
tree1ca626fe9551734d6d98e50b841b7365d49ba088 /CMakeLists.txt
parent891d57d200f55b91f80b6d3b4dd0c30479be6109 (diff)
downloadlibtwittercpp-7e85b35d7d1714e3f85434b891a1050ad584e337.tar.gz
libtwittercpp-7e85b35d7d1714e3f85434b891a1050ad584e337.tar.bz2
libtwittercpp-7e85b35d7d1714e3f85434b891a1050ad584e337.zip
Added ability to upload media and tweet it
Images (static and animated) and videos have been tested. Currently all media uploads occur in one large chunk; support to break down chunks will be added later.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 7507e25..9f290c9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ include_directories(vendor/liboauthcpp/include)
9add_subdirectory(vendor/curlcpp) 9add_subdirectory(vendor/curlcpp)
10include_directories(${CURLCPP_SOURCE_DIR}/include) 10include_directories(${CURLCPP_SOURCE_DIR}/include)
11 11
12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp) 12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp)
13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) 13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11)
14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) 14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(twitter++ oauthcpp curlcpp) 15target_link_libraries(twitter++ oauthcpp curlcpp)