diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-06-02 20:10:38 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-06-02 20:10:38 -0400 |
commit | 9fdcbee29350846db7f136b023da64bb2e6a93f5 (patch) | |
tree | 8fa6e2ee0e48c8b7310095989ef0a9838ddfcb37 /CMakeLists.txt | |
parent | e506eb6214ac1799ce7d7e333cfab965a11d5917 (diff) | |
parent | 442f1ee071152be04c4184473ddfee5040795b76 (diff) | |
download | libtwittercpp-9fdcbee29350846db7f136b023da64bb2e6a93f5.tar.gz libtwittercpp-9fdcbee29350846db7f136b023da64bb2e6a93f5.tar.bz2 libtwittercpp-9fdcbee29350846db7f136b023da64bb2e6a93f5.zip |
Merge branch 'master' of https://github.com/hatkirby/libtwittercpp
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 29a0a75..a0a1b0b 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -10,7 +10,7 @@ include_directories(vendor/liboauthcpp/include) | |||
10 | add_subdirectory(vendor/curlcpp) | 10 | add_subdirectory(vendor/curlcpp) |
11 | include_directories(${CURLCPP_SOURCE_DIR}/include) | 11 | include_directories(${CURLCPP_SOURCE_DIR}/include) |
12 | 12 | ||
13 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp) | 13 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp src/configuration.cpp) |
14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) | 14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) |
15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) | 15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) |
16 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) | 16 | target_link_libraries(twitter++ oauthcpp curlcpp curl pthread) |