diff options
author | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-20 15:34:44 -0400 |
---|---|---|
committer | Kelly Rauchenberger <fefferburbia@gmail.com> | 2016-05-20 15:34:44 -0400 |
commit | 0ccac89815ee92c69fefc148cfb272faf7309136 (patch) | |
tree | 228775a433018c8a5fd20f0ebb0f8446057b2112 /CMakeLists.txt | |
parent | f465dce27cf0f07039e29d8975ad98939f0df3a9 (diff) | |
download | libtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.tar.gz libtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.tar.bz2 libtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.zip |
Started implementing user streams
You can now start a user stream and end it yourself. If it disconnects abnormally, it will reconnect with a backoff as described by Twitter. Some data structures have some fields parsed now; tweets have IDs, text, and authors. Users have IDs, screen names, and names. Notifications from the stream are parsed completely. The ability to follow and unfollow users has also been added, as well as the ability to get a list of friends and followers, and to reply to a tweet.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 9f290c9..3c43670 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -3,13 +3,14 @@ project (twitter++) | |||
3 | 3 | ||
4 | include_directories(vendor/json/src) | 4 | include_directories(vendor/json/src) |
5 | 5 | ||
6 | set(LIBOAUTHCPP_BUILD_DEMOS FALSE) | ||
6 | add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL) | 7 | add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL) |
7 | include_directories(vendor/liboauthcpp/include) | 8 | include_directories(vendor/liboauthcpp/include) |
8 | 9 | ||
9 | add_subdirectory(vendor/curlcpp) | 10 | add_subdirectory(vendor/curlcpp) |
10 | include_directories(${CURLCPP_SOURCE_DIR}/include) | 11 | include_directories(${CURLCPP_SOURCE_DIR}/include) |
11 | 12 | ||
12 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp) | 13 | add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp) |
13 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) | 14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) |
14 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) | 15 | set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) |
15 | target_link_libraries(twitter++ oauthcpp curlcpp) | 16 | target_link_libraries(twitter++ oauthcpp curlcpp) |