about summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2016-05-20 15:34:44 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2016-05-20 15:34:44 -0400
commit0ccac89815ee92c69fefc148cfb272faf7309136 (patch)
tree228775a433018c8a5fd20f0ebb0f8446057b2112 /CMakeLists.txt
parentf465dce27cf0f07039e29d8975ad98939f0df3a9 (diff)
downloadlibtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.tar.gz
libtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.tar.bz2
libtwittercpp-0ccac89815ee92c69fefc148cfb272faf7309136.zip
Started implementing user streams
You can now start a user stream and end it yourself. If it disconnects abnormally, it will reconnect with a backoff as described by Twitter. Some data structures have some fields parsed now; tweets have IDs, text, and authors. Users have IDs, screen names, and names. Notifications from the stream are parsed completely. The ability to follow and unfollow users has also been added, as well as the ability to get a list of friends and followers, and to reply to a tweet.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 9f290c9..3c43670 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -3,13 +3,14 @@ project (twitter++)
3 3
4include_directories(vendor/json/src) 4include_directories(vendor/json/src)
5 5
6set(LIBOAUTHCPP_BUILD_DEMOS FALSE)
6add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL) 7add_subdirectory(vendor/liboauthcpp/build EXCLUDE_FROM_ALL)
7include_directories(vendor/liboauthcpp/include) 8include_directories(vendor/liboauthcpp/include)
8 9
9add_subdirectory(vendor/curlcpp) 10add_subdirectory(vendor/curlcpp)
10include_directories(${CURLCPP_SOURCE_DIR}/include) 11include_directories(${CURLCPP_SOURCE_DIR}/include)
11 12
12add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp) 13add_library(twitter++ src/client.cpp src/auth.cpp src/tweet.cpp src/codes.cpp src/notification.cpp src/direct_message.cpp src/list.cpp src/user.cpp)
13set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11) 14set_property(TARGET twitter++ PROPERTY CXX_STANDARD 11)
14set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON) 15set_property(TARGET twitter++ PROPERTY CXX_STANDARD_REQUIRED ON)
15target_link_libraries(twitter++ oauthcpp curlcpp) 16target_link_libraries(twitter++ oauthcpp curlcpp)