summary refs log tree commit diff stats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Rauchenberger <fefferburbia@gmail.com>2018-03-13 16:44:43 -0400
committerKelly Rauchenberger <fefferburbia@gmail.com>2018-03-13 16:44:43 -0400
commit62de4eb955181b7b00364cb14201a91268aa57b4 (patch)
tree4f15e6ac6ce1bb7097d5c98d5c337d5fdb597800 /CMakeLists.txt
parent31a8d2f8541384cfecfecfa5b872edb424b1ec14 (diff)
downloadgrunge-62de4eb955181b7b00364cb14201a91268aa57b4.tar.gz
grunge-62de4eb955181b7b00364cb14201a91268aa57b4.tar.bz2
grunge-62de4eb955181b7b00364cb14201a91268aa57b4.zip
Removed yaml-cpp submodule
Project now links against a local installation of yaml-cpp.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index d9b21f5..0eaaa10 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt
@@ -1,19 +1,23 @@
1cmake_minimum_required (VERSION 3.1) 1cmake_minimum_required (VERSION 3.1)
2project (grunge) 2project (grunge)
3 3
4set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
5
6add_subdirectory(vendor/libtwittercpp) 4add_subdirectory(vendor/libtwittercpp)
7add_subdirectory(vendor/verbly) 5add_subdirectory(vendor/verbly)
8add_subdirectory(vendor/yaml-cpp EXCLUDE_FROM_ALL)
9 6
10find_package(PkgConfig) 7find_package(PkgConfig)
8pkg_check_modules(yaml-cpp yaml-cpp REQUIRED)
11pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED) 9pkg_check_modules(GraphicsMagick GraphicsMagick++ REQUIRED)
12 10
13include_directories(${GraphicsMagick_INCLUDE_DIRS} vendor/verbly/lib vendor/libtwittercpp/src vendor/yaml-cpp/include vendor/libtwittercpp/vendor/curlcpp/include) 11include_directories(
12 vendor/libtwittercpp/src
13 vendor/libtwittercpp/vendor/curlcpp/include
14 vendor/verbly/lib
15 ${yaml-cpp_INCLUDE_DIRS}
16 ${GraphicsMagick_INCLUDE_DIRS})
17
14link_directories(${GraphicsMagick_LIBRARY_DIRS}) 18link_directories(${GraphicsMagick_LIBRARY_DIRS})
19
15add_executable(grunge main.cpp grunge.cpp palette.cpp) 20add_executable(grunge main.cpp grunge.cpp palette.cpp)
16set_property(TARGET grunge PROPERTY CXX_STANDARD 11) 21set_property(TARGET grunge PROPERTY CXX_STANDARD 11)
17set_property(TARGET grunge PROPERTY CXX_STANDARD_REQUIRED ON) 22set_property(TARGET grunge PROPERTY CXX_STANDARD_REQUIRED ON)
18target_link_libraries(grunge ${GraphicsMagick_LIBRARIES} verbly yaml-cpp twitter++) 23target_link_libraries(grunge ${yaml-cpp_LIBRARIES} ${GraphicsMagick_LIBRARIES} verbly twitter++)
19